2018 limited 8 multimedia screen freeze - Club Crosstrek | Subaru XV Crosstrek Forums
Club Crosstrek | Subaru XV Crosstrek Forums
 


Reply
 
Thread Tools Display Modes
 
Old 05-14-2018, 02:11 PM   #1
New Member
 
Join Date: May 2018
Posts: 3
Angry 2018 limited 8 multimedia screen freeze

My 8 multimedia screen froze on startup with radio blaring on starlink screen. It was so loud car was undriveable. All screen controls were unresponsive, even radio power on/off knob. Shuting and restarting car did not fix. Leaving car in garage overnight did.

Any suggestions to fix if it happens again? (I did read shorting the battery may work, but this seems like a poor solution)

teminior is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-14-2018, 02:19 PM   #2
Senior Member
 
stupidchicken03's Avatar
 
Join Date: Nov 2016
Posts: 421
My Vehicle: 05 big turbo STi - 18 ADF lifted Crosstrek
Default

There have been a lot of issues with the new 2018 Headunits.

The 2017 Impreza got them first and had issues as well.

You should check your settings and see what software version the headunit is running. Then call the dealer and ask if there is an update available. I had mine (premium, smaller screen) updated and it fixed a lot of issues I was having with the stereo.
__________________
stupidchicken03 is offline   Reply With Quote
Old 05-15-2018, 01:36 AM   #3
New Member
 
Join Date: May 2018
Posts: 3
Default

Thanks, but I updated to the latest software and added a driver profile before I brought the new car home. I’m guessing all Harmon Kardon head units have this problem but could show up in different ways. I talked to a dealer today and he was aware of it, no TSBs, and he does not know any solution to it. I hope they can fix it by a software update.
teminior is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-21-2018, 12:38 AM   #4
Member
 
MarioAndretti's Avatar
 
Join Date: Oct 2015
Posts: 22
My Vehicle: '16 Crosstrek premium
Default

Do not ever short the battery as that could cause it to blow up in your face.The solution is to disconnect the battery then reconnect it.


I know it's a totally different system but that's what I had to do with my old '02 Impreza.I shut the engine off and pulled out the key and the radio kept on playing.None of the controls responded and turning the engine on then back off didn't fix it.So I said to myself "I'll fix you" and I pulled the fuse to the radio and IT KEPT ON PLAYING.That car was possessed.Only disconnecting the battery would shut it off.
MarioAndretti is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 05:23 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.