2018 8 inch display problem - Club Crosstrek | Subaru XV Crosstrek Forums
Club Crosstrek | Subaru XV Crosstrek Forums
 


Reply
 
Thread Tools Display Modes
 
Old 08-31-2017, 02:23 PM   #1
Member
 
Join Date: Aug 2017
Posts: 13
My Vehicle: 2018 Crosstrek Limited
Default 2018 8 inch display problem

1,100 miles on my Limited Crosstrek with 8 inch infotainment screen - screen started acting up last week or so - functions OK and changes modes but colors all washed out and display sometimes does other weird screen scrolling of washed out color. Already have appt to have it looked at - curious if this might be a know issue? Seems like a hardware issue not software - functions are fine - just display itself.
Attached Images
File Type: png IMG_2405.png (1,000.7 KB, 25 views)

NHTerrys is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-31-2017, 02:42 PM   #2
Member
 
Join Date: Mar 2017
Posts: 47
Default

Have not come across this in any forums so far


Sent using Tapatalk
Becks is offline   Reply With Quote
Old 09-16-2017, 10:20 PM   #3
Member
 
Join Date: Sep 2017
Posts: 29
Default

I was able to crash the whole system by asking TomTom to look for restaurants.

I had to do a system restore to unlock it.

I haven't done that again yet.
Subaruplatt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-25-2017, 06:00 AM   #4
Member
 
Join Date: Sep 2017
Posts: 20
Default

System randomly crashes for me on startup. A couple times the screen didnít come on than about 30 seconds later the center stack lights cycled and it booted up. Itís full of bugs on the HK software. There is always a little ding noise that I thought was in the car but tonight it came out a dash tweeter and I know itís the radio. Itís random and has no meaning. Barely audible.


Sent from my iPhone using Tapatalk
radzer0 is offline   Reply With Quote
Old 09-28-2017, 04:25 AM   #5
New Member
 
Join Date: Sep 2017
Posts: 1
My Vehicle: 2018 Crosstrek Limited
Default

I too have been having problems with my 2018 crosstrek. After 6 days and 200 miles, it had static noises by front dashboard speaker even when the car is off. Dealer replaced the speakers, but static noise came back after 2 days. Replaced the radio, still same. Only until they replaced the amp did the noise go away. After being at the dealer for 2 weeks, the infotainment screen blacked out upon receiving an incoming call. Everything was still functioning (can hear radio, get calls, speak to voice command to get directions, even touchscreen responds), it's just that nothing is displayed on screen (or at least its very very dim and you can see some tiny bit of it if you put a flashlight next to screen), even the rear camera doesn't display on screen when you reverse. I've had the crosstrek less than a month, and it has spent more than half of its time at the dealer being fixed. It's still at the dealer currently, and they said they will replace the infotainment unit. Probably should have waited until all these bugs are fixed.
jannelle is offline   Reply With Quote
Old 09-28-2017, 08:38 AM   #6
Member
 
Join Date: Sep 2017
Posts: 20
Default

Iíve seen some dark screen stuff. I think itís software not hardware issues. Hope itís fixed up soon.


Sent from my iPhone using Tapatalk
radzer0 is offline   Reply With Quote
Old 10-16-2017, 10:09 PM   #7
Member
 
Join Date: Sep 2017
Posts: 20
Default

Well my new radio worked good for about 5 days. Itís crashing and rebooting and **** again.


Sent from my iPhone using Tapatalk
radzer0 is offline   Reply With Quote
Old 10-17-2017, 03:07 PM   #8
Member
 
NoVA Crosstreker's Avatar
 
Join Date: Apr 2016
Posts: 26
Default

No major issues so far on mine (which I only purchased this past Friday) except that it froze once as I was surfing Sirius stations -- I'd landed on a 70s station when it happened, so I had to listen to ABBA and the Village People and such all the way home. Couldn't turn off the radio or even turn down the volume or go to another app or anything. The car did go quiet when I got home and turned off the engine. And it had rebooted just fine when I turned the car on again an hour later. Any computer system can freeze, but to have a glitch like that within days of buying the car didn't seem like a good omen. I'll advise if it happens again. Other than that, I do like the infotainment system overall. The nav has worked flawlessly.
NoVA Crosstreker is offline   Reply With Quote
Old 10-17-2017, 03:49 PM   #9
Member
 
Join Date: Sep 2017
Posts: 20
Default

Itís definitely the software tho. The unit is actually corrupting itself over time. You would think they would have a way to update it via usb but apparently you have to replace the whole unit if it happens :/. I found a post about our system in the 18 outbacks and issues a lot of people are having.


Sent from my iPhone using Tapatalk
radzer0 is offline   Reply With Quote
Old 10-20-2017, 09:44 PM   #10
Member
 
Join Date: Oct 2017
Posts: 6
Default

My Limited '18 is having all the above problems as well - so far I have seen -
1) Screen completely frozen and none of the buttons on the unit work
2) On call and the bluetooth connection drops
3) When using NAV, the whole system reboots
4) While I was listening FM, there was a loud screech and it crashed

I am taking the car to the dealer today and lets see what if they could do something about it. Sadly the issue is not happening now. But I have taken a video of issue 1) above. Fingers crossed.

@jannelle: Please keep us posted
meistershifu is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 03:48 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.