Horns quit working on '13 - Club Crosstrek | Subaru XV Crosstrek Forums
Club Crosstrek | Subaru XV Crosstrek Forums
 


Reply
 
Thread Tools Display Modes
 
Old 10-01-2017, 06:34 PM   #1
Member
 
Bignick's Avatar
 
Join Date: Apr 2013
Posts: 38
Default Horns quit working on '13

Shortly after the warranty expired my horn would work intermittently, then it would only work if the steering wheel was significantly turned. Finally it quit altogether. I removed the air bag and checked the plug in connectors and wiring I could see. I also checked the fuse and relay.

I'm thinking it is a broken wire in the harness possibly under the dash. Any ideas? A link to a schematic, any help would be appreciated.

Bignick is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-03-2017, 11:39 PM   #2
Site Team
 
AWDfreak's Avatar
 
Join Date: Oct 2012
Posts: 2,570
My Vehicle: 2014 Subaru XV Crosstrek 5MT
Default

I do not have access to a schematic, but you could find that on an online service manual service such as AllDataDIY, or you could find the actual service manual if someone has uploaded it online for free-use.

Mine quit working after the warranty engine change, I have yet to discover why mine stopped working. I know this is specific to the circuit of the horn button as I can still activate the horn via the panic button.
__________________
"Why would I want to profess my feelings for some 3D girl?" - Tomoya Aki from the anime Saekano
AWDfreak is offline   Reply With Quote
Old 10-04-2017, 09:29 AM   #3
Member
 
MN Moose's Avatar
 
Join Date: Oct 2016
Posts: 96
My Vehicle: 2016 Crosstrek 2.0i Premium Desert Khaki
Default

There's a Panic Button??
MN Moose is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-04-2017, 10:44 AM   #4
Full Member
 
Join Date: May 2014
Posts: 100
My Vehicle: 2014 XV Crosstrek Limited CVT (ISM)
Default

Quote:
Originally Posted by MN Moose View Post
There's a Panic Button??
On the remote...
__________________
Mark
2014 XV Crosstrek CVT - Ice Silver Metallic
MarkEagleUSA is online now   Reply With Quote
Old 10-09-2017, 09:38 AM   #5
Member
 
MN Moose's Avatar
 
Join Date: Oct 2016
Posts: 96
My Vehicle: 2016 Crosstrek 2.0i Premium Desert Khaki
Default

Quote:
Originally Posted by MarkEagleUSA View Post
On the remote...
...oh, THAT Panic Button!
MN Moose is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 07:28 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.