remote weirdness? - Club Crosstrek | Subaru XV Crosstrek Forums
Club Crosstrek | Subaru XV Crosstrek Forums
 


Reply
 
Thread Tools Display Modes
 
Old 12-05-2017, 01:25 AM   #1
Member
 
Join Date: Jan 2017
Posts: 49
Default remote weirdness?

every once in a while, my '16 crosstrek doesn't respond to the remote lock/unlock. nothing.

i thought it might be corrosion on the contacts, so i took the fob apart, and put it back together. but it still happens once in a while. and at about the 1-year mark, i thought it might need a new battery, so i replaced the little lithium cell. but it didn't help, immediately, but did the same thing as before, not working for a minute or two, and then back to normal. in the meantime, i also tried my second remote, which didn't respond either. so it seems that the crosstrek is going "deaf" once in a while, and then "recovering" on its own. which is a real pain, for a car that sounds the alarm if you open it with the key, and doesn't even have a real trunk release.

has anybody run into something like this? and what did you do to fix it?

nielkmot is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-05-2017, 04:35 AM   #2
Site Team
 
AWDfreak's Avatar
 
Join Date: Oct 2012
Posts: 2,646
My Vehicle: 2014 Subaru XV Crosstrek 5MT
Default

We need a little more info than what you've provided.

Do you have the regular key, which requires using the key to physically turn the ignition switch, or do you have the proximity key that only requires that the key be in the vehicle to start the vehicle?

I have not had such an issue for my regular key fob. I've had my Subaru XV Crosstrek since it was new in 2014 and it has been just fine.
__________________
"Why would I want to profess my feelings for some 3D girl?" - Tomoya Aki from the anime Saekano
AWDfreak is offline   Reply With Quote
Old 12-05-2017, 06:11 AM   #3
Member
 
Join Date: Jan 2017
Posts: 49
Default

it's just a regular key, with the remote locking/unlocking transmitter in the head. the ignition is still a key switch, not a pushbutton start.

as far as i can tell, it's just a slight "improvement" over my '02 legacy, which had a separate key and fob, for remote lock/unlock. the new one's now just one piece, and also has an extra button for unlocking just the hatch - i'm still trying to find an excuse to use it. (a questionable design choice was to use a smaller battery, which will require replacing more often, and a softer plastic for the key head, which will get more marred with each replacement battery.)
nielkmot is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-06-2017, 02:05 AM   #4
Site Team
 
AWDfreak's Avatar
 
Join Date: Oct 2012
Posts: 2,646
My Vehicle: 2014 Subaru XV Crosstrek 5MT
Default

It sounds like you have an issue that may perhaps go beyond the key fob. I have had no such issues. It might require a Subaru Select Monitor to diagnose the issue, which means almost certainly a visit to your local Subaru dealership to get it checked.
__________________
"Why would I want to profess my feelings for some 3D girl?" - Tomoya Aki from the anime Saekano
AWDfreak is offline   Reply With Quote
Old 12-07-2017, 08:57 PM   #5
Member
 
Join Date: Jan 2017
Posts: 49
Default

you may be right. i just hate giving the dealer service department an "intermittent" problem that i can't reproduce on demand, because it's usually frustrating for me and them. i call it the "talking dog syndrome" (the dog only talks when there's no one else around). unfortunately, subaru has built this car so that it's completely unusable without a working key fob, so i can't really just let it go.

they used to blame these things on sunspots, and maybe it was better that way...
nielkmot is offline   Reply With Quote
Old 12-10-2017, 01:03 AM   #6
Member
 
Join Date: Feb 2017
Posts: 28
Default

Wireless control module?
Nanook is offline   Reply With Quote
Old 12-10-2017, 05:47 AM   #7
Member
 
Join Date: Jan 2017
Posts: 49
Default

probably (but i have no schematic or other data on the car).

would an intermittent problem likely be a loose connection, or a software bug? (if the module is damaged in some way, i would expect it to fail and stay failed.)

and how might it be "fixing" itself? is there any way, for mere mortals, to check for things like firmware versions, and maybe even update them?
nielkmot is offline   Reply With Quote
Old Today, 04:43 AM   #8
Site Team
 
AWDfreak's Avatar
 
Join Date: Oct 2012
Posts: 2,646
My Vehicle: 2014 Subaru XV Crosstrek 5MT
Default

I don't think there's any kind of wireless firmware updates for our vehicles.

A loose connection or occasional outside circumstance may possibly be the culprit(s).
__________________
"Why would I want to profess my feelings for some 3D girl?" - Tomoya Aki from the anime Saekano
AWDfreak is offline   Reply With Quote
Reply

Tags
remote unlock transmitter

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 08:25 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.