Access Key Not Detected - Club Crosstrek | Subaru XV Crosstrek Forums
Club Crosstrek | Subaru XV Crosstrek Forums
 


Reply
 
Thread Tools Display Modes
 
Old 05-28-2019, 01:21 PM   #1
Member
 
Join Date: Mar 2019
Posts: 15
My Vehicle: 2019 Crosstrek Limited Dark Blue Pearl
Default Access Key Not Detected

I have a 2019 Crosstrek Limited with Eyesight. In the past week or so I have randomly gotten a "Access Key Not Detected" warning and I could not lock or unlock my car using either one of my key FOBS.
I can lock the vehicle with the key and the alarm and everything works. I can get in the car an start it so the battery in the FOB are OK.

I cannot predict when it will work o not and the dealer said they have never head of this before. I told the dealer to google "access key not detected" and they will get several hundred thousand hits and they did...seemingly to their surprise. They said no one ever complained to them.
Anyway, it is a issue with me and a problem particularly for my Wife. Has anyone had this occur? How have you resolved it? What was the problem?
TIA


EDIT, nothing works on the FOB's, lock, unlock, rear hatch opens, emergency but the little red LED that indicates signal being sent flashes when button is pushed.


it did not work last night but it works this morning?

Pete_Coach is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-28-2019, 11:16 PM   #2
Member
 
Join Date: Mar 2019
Posts: 15
My Vehicle: 2019 Crosstrek Limited Dark Blue Pearl
Default

Just happened again. This time, it said to hold key to stat button to start the car as well as Access Key Not Detected.
Also, could not lock the car, even with the key..
Pete_Coach is offline   Reply With Quote
Old 05-29-2019, 04:02 AM   #3
Site Team
 
AWDfreak's Avatar
 
Join Date: Oct 2012
Posts: 2,940
My Vehicle: 2014 Subaru XV Crosstrek 5MT
Default

Are there additional items on the key ring, if equipped, on your Subaru key, that may perhaps be interfering with the signal of the keyless access fob?
__________________
"Why would I want to profess my feelings for some 3D girl?" - Tomoya Aki from the anime Saekano
AWDfreak is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-29-2019, 11:22 AM   #4
Member
 
Join Date: Mar 2019
Posts: 15
My Vehicle: 2019 Crosstrek Limited Dark Blue Pearl
Default

Quote:
Originally Posted by AWDfreak View Post
Are there additional items on the key ring, if equipped, on your Subaru key, that may perhaps be interfering with the signal of the keyless access fob?
Yes a garage door opener on my FOB. But, that has been on the key ring since we got the car. The issue just started a week and a bit ago.

It happens with my Wife's FOB as well and she has nothing on her key ring.
Pete_Coach is offline   Reply With Quote
Old 05-30-2019, 12:34 AM   #5
New Member
 
Join Date: May 2018
Posts: 4
Default access key not detectec

The same just happened to me for the first time after a year driving my 2018 crosstrek limited with eyesight. Restarted car, shutoff and message went away. I am guessing the key fob signal was blocked or a new head unit update may have changed how the key fob is now detected.
teminior is offline   Reply With Quote
Old 05-30-2019, 11:39 AM   #6
Member
 
Join Date: Mar 2019
Posts: 15
My Vehicle: 2019 Crosstrek Limited Dark Blue Pearl
Default

Quote:
Originally Posted by teminior View Post
The same just happened to me for the first time after a year driving my 2018 crosstrek limited with eyesight. Restarted car, shutoff and message went away. I am guessing the key fob signal was blocked or a new head unit update may have changed how the key fob is now detected.
Tried that numerous times. No effect at all. Still did not work.

All of the sudden it works...then yesterday, it stopped again. Then, last night, before I went to bed, without driving or starting the car, it worked.



Interesting about the head unit. I noticed yesterday that my AM and FM presets disappeared. I normally listen to XM but wanted the local sports on AM and all the presets were gone, except for XM.
Pete_Coach is offline   Reply With Quote
Old 05-30-2019, 11:42 AM   #7
New Member
 
Join Date: May 2017
Posts: 3
Default

I’ve had similar problems with a Nissan fob. I replaced the battery and no more issues
tfjonesjr is offline   Reply With Quote
Old 05-31-2019, 12:48 PM   #8
Member
 
Join Date: Mar 2019
Posts: 15
My Vehicle: 2019 Crosstrek Limited Dark Blue Pearl
Default

UPDATE:
Got an appointment with the Dealer yesterday. I did take a video of it not working and even the key not working. It actually did not work while at the dealer and they saw it for themselves. They changed the battery in the FOB's. It works...for now.
They had no explanation. They had not idea why the emergency key did not work as it is not connected to the FOB function..

I think it may come back but, will have to wait and see.


I also told them about the presets disappearing on the radio and they said this has happened before but they also do not know why.
Pete_Coach is offline   Reply With Quote
Old 06-03-2019, 03:23 PM   #9
Member
 
Join Date: Mar 2019
Posts: 15
My Vehicle: 2019 Crosstrek Limited Dark Blue Pearl
Default

Quote:
Originally Posted by Pete_Coach View Post
UPDATE:
Got an appointment with the Dealer yesterday. I did take a video of it not working and even the key not working. It actually did not work while at the dealer and they saw it for themselves. They changed the battery in the FOB's. It works...for now.
They had no explanation. They had not idea why the emergency key did not work as it is not connected to the FOB function..

I think it may come back but, will have to wait and see.


I also told them about the presets disappearing on the radio and they said this has happened before but they also do not know why.
UPDATE to the update.



Went to the dealer....could not duplicate it so they ordered me a new FOB. I told them the problem is with both FOB's but they only ordered one
Pete_Coach is offline   Reply With Quote
Old 06-21-2019, 01:56 PM   #10
Member
 
Join Date: Mar 2019
Posts: 15
My Vehicle: 2019 Crosstrek Limited Dark Blue Pearl
Default Update, to the Previous Update

Well, got a new (just one) key FOB. They said only one FOB and if that fixes it, then they will order another.
So, the new FOB worked for a week, then failed to lock the doors again. The old FOB did not work either. (took video to prove the faults)

Went back to the dealer and showed them the video and they took the car in he shop. This time they said the start button module antenna had corrosion on the connectors and they cleaned them (?). This should fix the problem, they said. Not sure how the start button module interacts with the lock function of the FOB but, that is all they are going to do....this time.
So, we will see how this works.

The saga continues
Pete_Coach is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 05:45 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.