Bluetooth connectability - Club Crosstrek | Subaru XV Crosstrek Forums
Club Crosstrek | Subaru XV Crosstrek Forums
 


Reply
 
Thread Tools Display Modes
 
Old 07-07-2015, 04:15 PM   #1
Member
 
Join Date: Sep 2014
Posts: 5
My Vehicle: 2014 XV Crosstrek Premium
Default Bluetooth connectability

I have the 14 premium trek. I been having problems with my new phone and the bluetooth. My old samsung galaxy s5 would connect everytime no problem. But my new HTC one m9 won't even connect by going into the bluetooth options on both car and phone to try to pair them. Anyone else have this problem or a remedy for it? Thanks.

EDIT: I forgot to mention that have tried the same phone on 3 other vehicles and theres zero issues with connectivity between them all. For some reason its just my crosstrek

STLsuby is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-07-2015, 10:49 PM   #2
Member
 
Join Date: Feb 2013
Posts: 14
My Vehicle: Crosstrek Premium CVT 2013 Marine Blue Pearl
Default

I had similar problems when I switched to Android Nexus 5 in my 2013 Premium Crosstrek. I now use this android app which solved most of the problem. You will need to play around with the settings.
Bluetooth Auto Connect.
If that one does not work; try others that are similar.
Steve_F is offline   Reply With Quote
Old 08-09-2015, 05:51 AM   #3
Member
 
Join Date: Feb 2015
Posts: 22
My Vehicle: 2014 Crosstrek Hybrid
Default

Try setting the code to 0000 instead of 1234 on the head unit. Then pair it using the voice commands from the steering wheel. That's what worked for my Note 4, found it buried on Android Central.
applezz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-19-2015, 06:03 AM   #4
Member
 
Join Date: Nov 2015
Posts: 37
Default

Quote:
Originally Posted by applezz View Post
Try setting the code to 0000 instead of 1234 on the head unit. Then pair it using the voice commands from the steering wheel. That's what worked for my Note 4, found it buried on Android Central.
I will dig up this old thread because I just purchased my car. My phone (Verizon Droid Turbo) wouldn't connect either. It keeps saying Scanning or something like that. Then it fails after about 30 seconds.

I found it strange that any manufacturer would be using either of the default BT codes. Most systems provide a random number to input, but I will chalk this up to mine being a preowned (read used) 2013 model year.

applezz,
I assume you are saying to change the code on the car system? If so, I will read up on how to do that with this interface.
__________________
2013 Crosstrek Limited
madmaxmutt is offline   Reply With Quote
Old 11-19-2015, 06:34 AM   #5
Member
 
Join Date: Feb 2015
Posts: 22
My Vehicle: 2014 Crosstrek Hybrid
Default

yep, on the radio head unit in the car
applezz is offline   Reply With Quote
Old 11-19-2015, 06:40 AM   #6
Member
 
Join Date: Nov 2015
Posts: 37
Default

Thanks, I'll give it a try tomorrow.

Sent from my XT1254 using Tapatalk
__________________
2013 Crosstrek Limited
madmaxmutt is offline   Reply With Quote
Old 11-19-2015, 12:54 PM   #7
Member
 
Join Date: Feb 2013
Posts: 14
My Vehicle: Crosstrek Premium CVT 2013 Marine Blue Pearl
Default Bluetooth Problem

Quote:
Originally Posted by madmaxmutt View Post
I will dig up this old thread because I just purchased my car. My phone (Verizon Droid Turbo) wouldn't connect either. It keeps saying Scanning or something like that. Then it fails after about 30 seconds.

I found it strange that any manufacturer would be using either of the default BT codes. Most systems provide a random number to input, but I will chalk this up to mine being a preowned (read used) 2013 model year.

applezz,
I assume you are saying to change the code on the car system? If so, I will read up on how to do that with this interface.
As far as I know the Crosstrek radio Bluetooth will only hold 1 device in memory. Being a used car there may already be the previous owners paired device in memory.
Delete that device ( if it is there). Then carefully go through the procedure for pairing (adding) a new device (your phone) to your car Bluetooth. I used the car default code 1234 on mine.
Let us know the results.
Steve_F is offline   Reply With Quote
Old 11-19-2015, 01:40 PM   #8
Member
 
Join Date: Nov 2015
Posts: 37
Default

Thanks. I'll check that, too.

Sent from my XT1254 using Tapatalk
__________________
2013 Crosstrek Limited
madmaxmutt is offline   Reply With Quote
Old 11-20-2015, 01:32 AM   #9
Member
 
Join Date: Nov 2015
Posts: 37
Default

The service guy tried several things to make this work after finding out it wouldn't work with his phone either. He verified that there was no paired device. He tried changing the PIN, but didn't try 0000. He disconnected the battery for a bit to attempt to reset the system.

We tried changing the code to 0000 in the Bluetooth audio device section. BTW, I have the screen/display, but not the nav system. That was the only time the phone then tried to pair and offered a PIN prompt. While it did pair as an audio device and successfully made a phone call, the next time I started the car (after I left) the phone was not connected. Then I did the phone pairing and that stayed in the system.

Bluetooth is an open standard and really should be easy to provide a fix (easier solution) for the customers, if the manufacturer spends a little time/money on the problem. I will also note that the service guy did mention that he did not know of any updates to the radio/Bluetooth system. I do hope Subaru figures out that they should support enhancements of existing systems.

Either way, it works now but should never be this difficult to do IMO.

Thanks to you guys for the help!!
__________________
2013 Crosstrek Limited
madmaxmutt is offline   Reply With Quote
Old 08-23-2016, 02:51 PM   #10
Member
 
Join Date: Jul 2015
Posts: 19
Default

I have a similar problem with my 13. I have to manually connect the phone every time I get in the car. I have to click into the BT settings and select the phone (the only phone in the system)
its a pain because I always forget to connect it before I start driving and once you are rolling the screen is locked out so I have to pull over to pair the phone.
I have tried all of the suggestions in this thread and I can not get it to automatically connect.
anyone figured this out? if not, anyone know how to defeat the screen lock out when moving?
thanks.
Chappy444 is offline   Reply With Quote
Reply


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 04:12 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.