Squeaking Sound in Storage Area - Club Crosstrek | Subaru XV Crosstrek Forums
Club Crosstrek | Subaru XV Crosstrek Forums
 


Reply
 
Thread Tools Display Modes
 
Old 05-30-2016, 11:37 AM   #1
mdg
Member
 
Join Date: Jan 2016
Posts: 11
Default Squeaking Sound in Storage Area

My 2016 developed a squeaking sound in the rear storage area. Only happens when I go over bumps. Checked out the hatch, spare tire and, everything seems tight. Any ideas?

mdg is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-30-2016, 05:00 PM   #2
Senior Member
 
Turkeytoe's Avatar
 
Join Date: Aug 2013
Posts: 259
My Vehicle: XV Crosstrek CVT Limited w/ Nav+Moonroof
Default

If it's still under the 36k warranty the dealer can take care of it. I'd start by looking at the trim around the pillars. I had a few squeaks in mine around the pillars that the dealer fixed way back when. They are tough to locate while you are driving, best thing would be to sit in the back while someone else drives so you can really look around. Find a nice bumpy gravel road/drive and start pressing on stuff to see if it stops.
__________________
Cupeez; LED Interior + License Plate Lights; Curt T Wiring Harness; Torklift EcoHitch; Weather Tech Floor Mats + Rain Deflectors; Kicker Speaker Upgrade

Turkeytoe is offline   Reply With Quote
Old 06-01-2016, 03:10 PM   #3
Full Member
 
keithwceb2's Avatar
 
Join Date: Feb 2015
Posts: 153
My Vehicle: 2019 Crosstrek Limited -Orange
Default

My husband's 2015 Hybrid had the same thing. It's the hatchdoor, plastic trim, right in the area of where it latches shut to the body. My Subaru dealer's mechanic told us that he's seen over 25 of these this year. Hasn't come back since they "fixed" whatever it was. (On the invoice it said repair loose trim.)

Hope this helps!
-Keith
keithwceb2 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-03-2016, 05:16 PM   #4
Full Member
 
keithwceb2's Avatar
 
Join Date: Feb 2015
Posts: 153
My Vehicle: 2019 Crosstrek Limited -Orange
Default

Quote:
Originally Posted by keithwceb2 View Post
My husband's 2015 Hybrid had the same thing. It's the hatchdoor, plastic trim, right in the area of where it latches shut to the body. My Subaru dealer's mechanic told us that he's seen over 25 of these this year. Hasn't come back since they "fixed" whatever it was. (On the invoice it said repair loose trim.)

Hope this helps!
-Keith
I stand corrected on my above posting. I pulled the maint. paperwork.
They have written down that trunk-latch needed lubrication/grease.
-Keith
keithwceb2 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 07:35 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.