Finally got my install under way... - Club Crosstrek | Subaru XV Crosstrek Forums
Club Crosstrek | Subaru XV Crosstrek Forums
 


Reply
 
Thread Tools Display Modes
 
Old 04-08-2014, 08:02 PM   #1
Member
 
Join Date: Jan 2014
Posts: 26
My Vehicle: 2014 XV Crosstrek 5MT, Dark Gray Metallic
Default Finally got my install under way...

Audison Bit TEN D processor, Alpine PDX -V9 5 channel amplifier, Silver Flute midbass, SB Acoustics based NVX tweeters, Kenwood 12" subwoofer, deadened doors and sparetire well...




















beaver is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-08-2014, 09:16 PM   #2
Senior Member
 
coletrain's Avatar
 
Join Date: Jul 2013
Posts: 275
My Vehicle: 2013 XV Crosstrek Limited CVT- Satin White Pearl
Default Re: Finally got my install under way...

what is the white part under the tweet? I figure its a custom mount traced from the old tweet frame, but what its made of? Or can you buy it just like its shown?
__________________
2013 XV Crosstrek Limited CVT- Satin White Pearl - See you in the Chattahoochee National Forest
coletrain is offline   Reply With Quote
Old 04-08-2014, 09:33 PM   #3
Member
 
Join Date: Jan 2014
Posts: 26
My Vehicle: 2014 XV Crosstrek 5MT, Dark Gray Metallic
Default Re: Finally got my install under way...

subaruaudio.net... He makes them to fit whichever tweeters you own.
beaver is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-08-2014, 09:42 PM   #4
Senior Member
 
coletrain's Avatar
 
Join Date: Jul 2013
Posts: 275
My Vehicle: 2013 XV Crosstrek Limited CVT- Satin White Pearl
Default Re: Finally got my install under way...

Didn't know he did tweets too. I did see his spacers on you door. Thanks!
__________________
2013 XV Crosstrek Limited CVT- Satin White Pearl - See you in the Chattahoochee National Forest
coletrain is offline   Reply With Quote
Old 04-11-2014, 02:35 PM   #5
New Member
 
Join Date: Dec 2013
Posts: 1
Default Re: Finally got my install under way...

Nice install beaver!

Question though, did you retain the stock HU?
If yes, i assume you used an LOC to connect to the Audison processor? Thanks.
Gian is offline   Reply With Quote
Old 04-11-2014, 11:15 PM   #6
Member
 
Join Date: Jan 2014
Posts: 26
My Vehicle: 2014 XV Crosstrek 5MT, Dark Gray Metallic
Default Re: Finally got my install under way...

I did retain the OEM head-unit. The use of a processor, such as this one does not require a LOC. Just tap into the speaker wires, power, ground and a switched power supply and then run RCA's from the processor to the amp(s) and you're off and running.


Sent from my iPhone using Tapatalk
beaver is offline   Reply With Quote
Old 05-24-2014, 05:23 AM   #7
Member
 
Join Date: Apr 2014
Posts: 10
My Vehicle: 2014 Crosstrek
Default Re: Finally got my install under way...

what did you use on the door panels to reduce the noise. Nice write up BTW
YoBen is offline   Reply With Quote
Old 07-08-2014, 08:06 PM   #8
Member
 
Join Date: Jan 2014
Posts: 26
My Vehicle: 2014 XV Crosstrek 5MT, Dark Gray Metallic
Default Re: Finally got my install under way...

Finally replaced my faulty Audison Bit TEN D with a Rockford Fosgate 3SIXTY.3. Hands down a better processor. I'm starting to really enjoy it.



beaver is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 05:56 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.