Subaru XV Crosstrek Forums banner

1 - 20 of 66 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
1,100 miles on my Limited Crosstrek with 8 inch infotainment screen - screen started acting up last week or so - functions OK and changes modes but colors all washed out and display sometimes does other weird screen scrolling of washed out color. Already have appt to have it looked at - curious if this might be a know issue? Seems like a hardware issue not software - functions are fine - just display itself.
 

Attachments

·
Registered
Joined
·
306 Posts
I was able to crash the whole system by asking TomTom to look for restaurants.

I had to do a system restore to unlock it.

I haven't done that again yet.
 

·
Registered
Joined
·
25 Posts
System randomly crashes for me on startup. A couple times the screen didn’t come on than about 30 seconds later the center stack lights cycled and it booted up. It’s full of bugs on the HK software. There is always a little ding noise that I thought was in the car but tonight it came out a dash tweeter and I know it’s the radio. It’s random and has no meaning. Barely audible.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1 Posts
I too have been having problems with my 2018 crosstrek. After 6 days and 200 miles, it had static noises by front dashboard speaker even when the car is off. Dealer replaced the speakers, but static noise came back after 2 days. Replaced the radio, still same. Only until they replaced the amp did the noise go away. After being at the dealer for 2 weeks, the infotainment screen blacked out upon receiving an incoming call. Everything was still functioning (can hear radio, get calls, speak to voice command to get directions, even touchscreen responds), it's just that nothing is displayed on screen (or at least its very very dim and you can see some tiny bit of it if you put a flashlight next to screen), even the rear camera doesn't display on screen when you reverse. I've had the crosstrek less than a month, and it has spent more than half of its time at the dealer being fixed. It's still at the dealer currently, and they said they will replace the infotainment unit. Probably should have waited until all these bugs are fixed.
 

·
Registered
Joined
·
25 Posts
I’ve seen some dark screen stuff. I think it’s software not hardware issues. Hope it’s fixed up soon.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
25 Posts
Well my new radio worked good for about 5 days. It’s crashing and rebooting and **** again.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
26 Posts
No major issues so far on mine (which I only purchased this past Friday) except that it froze once as I was surfing Sirius stations -- I'd landed on a 70s station when it happened, so I had to listen to ABBA and the Village People and such all the way home. Couldn't turn off the radio or even turn down the volume or go to another app or anything. The car did go quiet when I got home and turned off the engine. And it had rebooted just fine when I turned the car on again an hour later. Any computer system can freeze, but to have a glitch like that within days of buying the car didn't seem like a good omen. I'll advise if it happens again. Other than that, I do like the infotainment system overall. The nav has worked flawlessly.
 

·
Registered
Joined
·
25 Posts
It’s definitely the software tho. The unit is actually corrupting itself over time. You would think they would have a way to update it via usb but apparently you have to replace the whole unit if it happens :/. I found a post about our system in the 18 outbacks and issues a lot of people are having.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6 Posts
My Limited '18 is having all the above problems as well - so far I have seen -
1) Screen completely frozen and none of the buttons on the unit work
2) On call and the bluetooth connection drops
3) When using NAV, the whole system reboots
4) While I was listening FM, there was a loud screech and it crashed

I am taking the car to the dealer today and lets see what if they could do something about it. Sadly the issue is not happening now. But I have taken a video of issue 1) above. Fingers crossed.

@jannelle: Please keep us posted :)
 

·
Registered
Joined
·
306 Posts
I haven?t had any additional problems yet. I did update my phone (6s) to iOS 11 additionaly.
I wish wireless CarPlay was implemented because every time I bump the cable it rejects the phone and ends up on radio. I have my car checking for updates and so far none are forthcoming. I love Apple Music playlists
 

·
Registered
Joined
·
25 Posts
If any of y’all goto a dealer tell them when they talk to Subaru you have talked to other people on the forums of similar issues. We don’t have as many crosstrek out there but there is more and more outback owners with the same issues.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6 Posts
I went to the dealer on Friday and they checked if the infotainment system needs any updates. They tried to upgrade the system anyway and they saw the symptom which I described to them earlier. They have ordered a replacement system and I am going to get it installed this weekend. Hopefully it would help!
 

·
Registered
Joined
·
25 Posts
I went to the dealer on Friday and they checked if the infotainment system needs any updates. They tried to upgrade the system anyway and they saw the symptom which I described to them earlier. They have ordered a replacement system and I am going to get it installed this weekend. Hopefully it would help!


Mine worked from Thursday till the following Tuesday and back to the same issues. My new unit the volume is completely different. This one at 28 is louder than the old one all the way up. I don’t believe the amp is on the head unit neither. I think it’s under the passenger seat if I remember right.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
306 Posts
Now it?s completely rejecting car play but only playing music as if I where an iPod. I?m still in the process of trying to figure out a work arround by trying to enable hey seri etc.
 

·
Registered
Joined
·
25 Posts
Now it?s completely rejecting car play but only playing music as if I where an iPod. I?m still in the process of trying to figure out a work arround by trying to enable hey seri etc.


Delete carplay on your phone and try reconnecting. It helps sometimes. If not do a factory reset. Don’t put it off too long tho. The software gets too corrupt to reset.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
26 Posts
One thing that would be helpful is if 18 owners who AREN'T having any issues with their 8-in display would chime in -- if there are any with flawless performance so far. I'm coming up on two weeks of ownership on mine and, so far, only one crash of the system (knock on wood). Curious if 20% of 18s are having issues or 60% or 90%. Hard to tell since, logically, those with no complaints have nothing to vent about and are less likely to post on this thread. If my system crashes a couple times a year, no biggie. Computers crash. iPhones crash. I think my printer has frozen once or twice. It happens. But if it's constant, or the crashing causes the overall system to degrade over time, that's a problem and Subaru might have an expensive piece of equipment to replace in a whole lot of vehicles. And if the replacement units don't have all the bugs ironed out, the problem will go on and on.
 

·
Registered
Joined
·
74 Posts
Picked up mine August 11th and have had no issues so far. I haven't used a usb stick in it yet and probably won't.

Using an iphone
 
1 - 20 of 66 Posts
Top