Subaru XV Crosstrek Forums banner

1 - 20 of 23 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1 (Edited)
I have a 2019 Crosstrek Limited with Eyesight. In the past week or so I have randomly gotten a "Access Key Not Detected" warning and I could not lock or unlock my car using either one of my key FOBS.
I can lock the vehicle with the key and the alarm and everything works. I can get in the car an start it so the battery in the FOB are OK.

I cannot predict when it will work o not and the dealer said they have never head of this before. I told the dealer to google "access key not detected" and they will get several hundred thousand hits and they did...seemingly to their surprise. They said no one ever complained to them.
Anyway, it is a issue with me and a problem particularly for my Wife. Has anyone had this occur? How have you resolved it? What was the problem?
TIA


EDIT, nothing works on the FOB's, lock, unlock, rear hatch opens, emergency but the little red LED that indicates signal being sent flashes when button is pushed.


it did not work last night but it works this morning?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #2
Just happened again. This time, it said to hold key to stat button to start the car as well as Access Key Not Detected.
Also, could not lock the car, even with the key..
 

·
Super Moderator
Joined
·
2,941 Posts
Are there additional items on the key ring, if equipped, on your Subaru key, that may perhaps be interfering with the signal of the keyless access fob?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #4
Are there additional items on the key ring, if equipped, on your Subaru key, that may perhaps be interfering with the signal of the keyless access fob?
Yes a garage door opener on my FOB. But, that has been on the key ring since we got the car. The issue just started a week and a bit ago.

It happens with my Wife's FOB as well and she has nothing on her key ring.
 

·
Registered
Joined
·
4 Posts
access key not detectec

The same just happened to me for the first time after a year driving my 2018 crosstrek limited with eyesight. Restarted car, shutoff and message went away. I am guessing the key fob signal was blocked or a new head unit update may have changed how the key fob is now detected.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
The same just happened to me for the first time after a year driving my 2018 crosstrek limited with eyesight. Restarted car, shutoff and message went away. I am guessing the key fob signal was blocked or a new head unit update may have changed how the key fob is now detected.
Tried that numerous times. No effect at all. Still did not work.

All of the sudden it works...then yesterday, it stopped again. Then, last night, before I went to bed, without driving or starting the car, it worked.



Interesting about the head unit. I noticed yesterday that my AM and FM presets disappeared. I normally listen to XM but wanted the local sports on AM and all the presets were gone, except for XM.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #8
UPDATE:
Got an appointment with the Dealer yesterday. I did take a video of it not working and even the key not working. It actually did not work while at the dealer and they saw it for themselves. They changed the battery in the FOB's. It works...for now.
They had no explanation. They had not idea why the emergency key did not work as it is not connected to the FOB function..

I think it may come back but, will have to wait and see.


I also told them about the presets disappearing on the radio and they said this has happened before but they also do not know why.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #9
UPDATE:
Got an appointment with the Dealer yesterday. I did take a video of it not working and even the key not working. It actually did not work while at the dealer and they saw it for themselves. They changed the battery in the FOB's. It works...for now.
They had no explanation. They had not idea why the emergency key did not work as it is not connected to the FOB function..

I think it may come back but, will have to wait and see.


I also told them about the presets disappearing on the radio and they said this has happened before but they also do not know why.
UPDATE to the update.



Went to the dealer....could not duplicate it so they ordered me a new FOB. I told them the problem is with both FOB's but they only ordered one :rolleyes:
 

·
Registered
Joined
·
19 Posts
Discussion Starter #10
Update, to the Previous Update

Well, got a new (just one) key FOB. They said only one FOB and if that fixes it, then they will order another.
So, the new FOB worked for a week, then failed to lock the doors again. The old FOB did not work either. (took video to prove the faults)

Went back to the dealer and showed them the video and they took the car in he shop. This time they said the start button module antenna had corrosion on the connectors and they cleaned them (?). This should fix the problem, they said. Not sure how the start button module interacts with the lock function of the FOB but, that is all they are going to do....this time.
So, we will see how this works.

The saga continues :)
 

·
Registered
Joined
·
19 Posts
Discussion Starter #11
Sad to say but, whatever they did, it did not fix it. The FOB would not lock the door again. Went to the store, it worked. Went over to a buddies place, it would not work
Went back to the dealer, told them after 6 times, I am fed up. Take my car and fix it but I need a loaner. They will call me when they have a courtesy car available....


Thing is, am I the only one that has this problem? I was hoping that someone in the community has or had suffered with the same problems.

When I googled "Subaru Access Key is not detected" I get lots of hits but no one seems to have a fix.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #13
if only there was a way you could manually lock/unlock the doors
Yes. I asked about that and there appears to be no way to unlock the car manually without triggering the alarm. How is this possible? Seems everything is connected electronically.
 

·
Registered
Joined
·
2 Posts
Hello! I also had this problem with my 2017. It happened infrequently, and the mechanics could never fix it. I had them replace my key fob and it has never happened again. Good luck!
 

·
Registered
Joined
·
19 Posts
Discussion Starter #16
Hello! I also had this problem with my 2017. It happened infrequently, and the mechanics could never fix it. I had them replace my key fob and it has never happened again. Good luck!
If Canada has a lemon law like ours, you should look into it. Good luck

Sent from my SM-G892U using Tapatalk
I have had both FOBs battery changes and re-programed and replaced, no change.


There is no "lemon law" in Canada.


They had the car for 3 days but could not replicate the issue while on their lot. They said they called Subaru engineering and this problem has never come up before even though you can get a couple hundred thousand hits if you google the problem. I have videoed the problem to show them.



I have been on vacation the past 3 weeks and came back and yup, it still is a problem Will have to take it back....again.
 

·
Registered
Joined
·
26 Posts
If it's not the transmitting fob then it's between the receiver and the receivers antenna that is intermittent. You have video documentation. They should replace the receiver.

Sent from my SM-G892U using Tapatalk
 

·
Registered
Joined
·
19 Posts
Discussion Starter #18
If it's not the transmitting fob then it's between the receiver and the receivers antenna that is intermittent. You have video documentation. They should replace the receiver.

Sent from my SM-G892U using Tapatalk
There are 3 antennas and they supposedly are working fine (they say they tested them).
 

·
Registered
Joined
·
26 Posts
There are 3 antennas and they supposedly are working fine (they say they tested them).
With your intermittent problem, their test means nothing, unless performed during the malfunction. Of the antennas, one is for satellite radio, one is GPS, and the 3rd is your communication fob, iirc.
They should reprogram the cpu controlling the wireless functions.
They should swap out the control unit second if that doesn't solve it. If the problem is gone, that was it. If problem persists, reinstall the original control unit and replace the entire antenna run. This needs to be approached as a computer /software issue, and assigned to the right technician. Good luck

Sent from my SM-G892U using Tapatalk
 

·
Registered
Joined
·
19 Posts
Discussion Starter #20
With your intermittent problem, their test means nothing, unless performed during the malfunction. Of the antennas, one is for satellite radio, one is GPS, and the 3rd is your communication fob, iirc.
They should reprogram the cpu controlling the wireless functions.
They should swap out the control unit second if that doesn't solve it. If the problem is gone, that was it. If problem persists, reinstall the original control unit and replace the entire antenna run. This needs to be approached as a computer /software issue, and assigned to the right technician. Good luck

Sent from my SM-G892U using Tapatalk
According to the owners manual Pg 2-4 the figure shows 5 antennas for key FOB and starting. The GPS and Satellite are different
 
1 - 20 of 23 Posts
Top