Subaru XV Crosstrek Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I purchased a used 2013 Crosstrek last May. It's hot around here, so since I purchased the vehicle I have been using the AC full time. Have not had a reason to use the heater till this AM. Tried turning the temperature knob all the way to hot, but the air coming out of the vents does not seem to change temperature no matter what the temperature dial is set on.

I continued playing around with it and also realized that the air flow selection knob (on the left), does not seem to be working. No matter what setting I choose I am getting air blowing from the dash front and also from the bottom of the dash, hitting my feet. I can not get air to come out of the top vents for defrost, or have air coming only to the bottom, etc.

Is it possible that there is simply some wires loose behind the climate controls? I did have my sound system upgraded last month, so I know the front bezel was probably pulled out, so I am wondering if the audio guy disconnected something by mistake? Is this possible? Any other reason why this could be happening? The blower control works correctly, and he AC works fine, so it is not a complete disconnect, but perhaps there is more than one wire connecting the assembly?

Thanks.
 

·
Super Moderator
Joined
·
2,941 Posts
Sounds like a wiring/electrical issue. My brother's 4th gen Impreza exhibited the same issues when he got his Impreza, as it had an aftermarket audio headunit installed.

The shop that fixed it found a mess of electrical wiring.
 

·
Registered
Joined
·
20 Posts
Our brand new Crosstrek only blew air on full blast, none of the other settings worked. The dealer had to swap the switch. Could be faulty switches

Sent from my A0001 using Tapatalk
 
1 - 3 of 3 Posts
Top