Subaru XV Crosstrek Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
603 Posts
Discussion Starter #1
Hi Trekkers,

Here's one I would like to see if any one else has the same thing.

So, take a look at the ignition tumbler (the place where your key goes in). Does your key tumbler look like mine?

Mine looks like there is a piece missing! Looking closely at the photo, around the metal rim that says: "Lock - Acc - Start - On"... you can see a part of the unit from underneath. And there is a gap between the tumbler and the plastic shell it sits in.

This seems odd or.. unfinished to me. Seems like there should be another plastic rim fitting around that. This photo is exactly how I received the car from the dealer.

Comparing the two attached images: The first one (keygap.jpg) is photo of mine. The second image (KeygapClosed.jpg) is what I think it should look like.. at least a little bit!

Any one else's Trek looks like it "missing" this ring to fill that gap??

Thanks.
 

Attachments

·
Registered
Joined
·
927 Posts
I have to say I agree with you... Something doesn't seem right. I just took this pic of my ignition. Seething is missing from yours.



EDIT:

I think I see it... You have a chrome ignition bezel and mine is black. Could that be it? Also, I too have the backlight around mine ( it's red) where the one you posted is blue. Do you have a backlight?

Just noticed something else... The one with the blue backlighting not be an XV... The plastic is sunk in. Yours and mine are flush or rounded out a bit

Sent from my iPhone 4s using Tapatalk
 

·
Registered
Joined
·
354 Posts
avimia said:
Hi Trekkers,

Here's one I would like to see if any one else has the same thing.

So, take a look at the ignition tumbler (the place where your key goes in). Does your key tumbler look like mine?

Mine looks like there is a piece missing! Looking closely at the photo, around the metal rim that says: "Lock - Acc - Start - On"... you can see a part of the unit from underneath. And there is a gap between the tumbler and the plastic shell it sits in.

This seems odd or.. unfinished to me. Seems like there should be another plastic rim fitting around that. This photo is exactly how I received the car from the dealer.

Comparing the two attached images: The first one (keygap.jpg) is photo of mine. The second image (KeygapClosed.jpg) is what I think it should look like.. at least a little bit!

Any one else's Trek looks like it "missing" this ring to fill that gap??

Thanks.

Ours looks like yours when it's not lit..ours is red when lit but it has that same gap...I woulda never noticed though!lol
 

·
Registered
Joined
·
603 Posts
Discussion Starter #4
Great inputs so far.

so that's one with a fitted ring.. and one without.

So, I'm wondering what would cause this inconsistency and how to get it fixed. Since the "standard" seems to be inconsistent, I have visions of my dealer saying.. "Yeah. That's the way they come. But we can add a fitting for.. CHA CHING".

I don't think a Subie owner should have to cha ching for something that should be on the car (missing or not.. it looks crappy and unfinished).

Any one know if the "fitted" piece is "standard and expected"? I am hoping to find some sort of solid reference or evidence to give to the dealer maybe.
 

·
Registered
Joined
·
714 Posts
I believe there is a TSB to be preformed at customer request on this exact issue. It seems like most of them are not centered in the housing. Mine is off as well although it doesn't bother me.
 

·
Registered
Joined
·
603 Posts
Discussion Starter #7
Hi Subir_roo,

Thanks for the info. Yes, mine is off center... but it does bug me. If a person is not careful, you can poke your key in to the gap. That could become an issue at any rate.

This is one of those stupid things that Subaru will no-doubt fix on later models. And a few years from now, if I go to trade it in, they'll try to gig me on it saying it was broken and lessen the value.

Any idea where I could get a copy of the TSB to give to the dealer? I need something concrete to give him since.. when I showed it to him before I left the lot, he just looked like a deer-in-the-headlights and shrugged. So, I am hoping to walk in with something "official" if possible to show them they should fix this.
 

·
Registered
Joined
·
500 Posts
Mine looks off as well, though not by as much. Doesn't really bother me, but I may go ahead and have it fixed if there's a TSB
 

·
Registered
Joined
·
714 Posts
The TSBs are not avaialable to the general public without paying for them but I have to go by work today so I will try to get the title and number of the TSB that you can give to your dealer to pull it up.

The gap on yours is larger than on mine so I can see where that might cause a problem.
 

·
Registered
Joined
·
603 Posts
Discussion Starter #10
Hi Subir_roo,

Thank you so much for this! Any kind of information would be very helpful. Will look forward to your post!
 

·
Registered
Joined
·
714 Posts
I'm at work now and can't find an active TSB for this. There was talk of one on another forum but I guess Subaru does not have an official TSB for this issue yet. :-\
 

·
Registered
Joined
·
6 Posts
Hi,
Sorry to resurrect this thread up, but I just got a 2 week old 2019 Crosstrek Premium and I also noticed the gap. The coil is exposed when u look inside. I wonder if all Crosstreks are like this.

 
1 - 12 of 12 Posts
Top