Subaru XV Crosstrek Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everyone.
I am a brand new member of the club.
I live in Toronto.
My vehicle is 3 months old: 2019 Crosstrek Limited which is the highest model available in Canada.
I have the 8" head unit with the Harmon Kardon system.
I am ready to tear my hair out!!
Issue #1:
My phone is an LG V30.
Android Auto - when it works it is great but most of the time it doesn't work.
I have tried 3 USB cables. The message I see most frequently on the screen is something like: "There is a bad connection with your USB - unplug and try again". This does absolutely nothing.
Sometimes I will actually connect and then either my Waze audio or Spotify starts playing through my PHONE speaker!!
Many times there is just co connection qt all and the Android Auto icon on the car screen remains greyed out.
FYI - my phone Android Auto app works.
I have tried all kinds of settings on the phone (USB debugging, etc>)

Issue #2:
The built in Subaru system:
The whole system has froze 3 times in the last week.
Today was the worst example.
I pushed on the talk switch on the steering wheel and said:
"Navigate to: and then spoke the address clearly". On my main das small screen a message pops up saying "please wait" and then does nothing.
The entire system froze: Navigation, radio, bluetooth, etc...
I turned off the ignition and waited about 5 minutes and then started the car to no avail. DEAD.
I made it home and called the dealer and he gave me the dreaded answer which is my most hated pet peeve: "You are the first person who has had this issue". I have an appointment tomorrow morning at 8:30. He said they would do a hard reset on the system
My understanding is that the dealer gets their service info for these matters from the Subaru Tech team so I am not expecting anyone at the dealer to know what to do if these problems persist.
I am hoping that one of the club members can give me some advice as to what to do going forward.
Am I unique with these issues or is the dealer pulling my leg?
Will replacing the system due anything or is that just a waste of time?
Sorry to vent - I am just so frustrated!!
Regards from a frozen (pardon the pun) Canuck
 

·
Super Moderator
Joined
·
800 Posts
Not sure about the 19's but the 18's had a lot of stereo issues when they first came out, sounds very familiar with what you're experiencing.

I would call your local dealer and see if there is a software update for the head unit.

I think there have been two (at least one for sure) for the 18's since they were released. Those helped solve A LOT of issues.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I just came back from the dealer.
At this point there are no new software updates available.
However, the dealer tech spoke to Subaru Tech at their head office and apprarently they are aware of some of the issues and apparantly an update is expected in about 2 weeks.
Let's hope that they are telling the truth about this.
 

·
Registered
Joined
·
71 Posts
I just came back from the dealer.
At this point there are no new software updates available.
However, the dealer tech spoke to Subaru Tech at their head office and apprarently they are aware of some of the issues and apparantly an update is expected in about 2 weeks.
Let's hope that they are telling the truth about this.
What version do you have currently (in Settings)? The latest I'm aware of is: Rel_U0.18.43.20 NA_CAN_MEX (bundled with the nav update).
 
1 - 4 of 4 Posts
Top