Subaru XV Crosstrek Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I have a 2019 crosstrek premium and I took my car in a reputable car stereo specialist store in my town. I had them put in 6 alpine speakers and a kicker key amp. The set up sounds amazing except afterwords I kept getting emails from STARLINK because the red light is on. I took it back and showed them a thread I found on this site explaining exactly what was wrong and how to fix it. They supposably fixed it and the red light is still on. I went to the dealer and ask them about it and they said they wouldn’t mess with it because they have no clue how they wired it. I understand that but they acted like they didn’t want to mess with it. I’m frustrated because I don’t know what to do if the audio store can’t fix it and the dealer won’t mess with it. I feel as if I should of left well enough alone or just paid the dealer an outrageous amount for there so so upgrade..
 

·
Registered
Joined
·
8 Posts
Discussion Starter #2
I just want to give an update on my speaker/amp upgrade nightmare. The issue is fixed !! what the stereo store did to finally get the green light on my STARLINK system is they added a FIX-LSA-4 4-channel load sensing adapter by JL audio.
 

·
Registered
Joined
·
5 Posts
I just want to give an update on my speaker/amp upgrade nightmare. The issue is fixed !! what the stereo store did to finally get the green light on my STARLINK system is they added a FIX-LSA-4 4-channel load sensing adapter by JL audio.
Thanks for this post as I have the same problem with my 2019 Crosstrek premium after installing an amplifier, and can hardly find any information anywhere on this. I find it hard to believe that more people aren't having this problem. Can you tell me if it changed the sound quality? did it change the loudness at all? And how exactly was this wired in, I'm guessing that it was plugged in to the head unit somehow? Thanks
 
1 - 3 of 3 Posts
Top