Subaru XV Crosstrek Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Has anyone else noticed the delay? Every time I press any button on the touchscreen, I have to wait 1-2 seconds for it to respond. Even the volume knob has a small delay, of perhaps 200ms. This is on a 2018 premium model. It's very frustrating. Hopefully it can be fixed with a software update. If I buy one of these, I would have to replace the head unit right away.
 

·
Registered
Joined
·
310 Posts
Try a factory reset. My unit did this when it was new. Since then I always use the best phone cables and never plug in multiple devices.

I charge secondary devices from a lighter USB fast charger

Is yours one with NAV as well ? There’s a free map update out for that. I really can’t say what made those gremlins go away for me. I always keep my IPHONE up to date. Trying iOS beta now and liking it.
 

·
Registered
Joined
·
21 Posts
Mine is the same way. I've updated it through the phone app, but it didn't help. It's slower that a Blackberry tablet I have from 2010.

Getting it to read mp3's from a flash drive is a joke too. It works about 50% of the time, and stops working for no apparent reason. When it works, it's great. It reads the tags and even shows the embedded album art. But then you stop and start the car and it will just say "loading media..." and never do anything. You have to unplug and re-plug the flash drive.

The only thing that works consistently is the Bluetooth. But again, using the touchscreen to scroll my contact list to make a call in the car is horribly slow.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #4
No nav on this model. The lag has nothing to do with my phone because it's even slow to open the settings screen, change volume, etc.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #5
CarPlay is also disappointing. With the iPhone USB connected, music occasionally sounds crackly for a few seconds and then goes back to normal. I've used CarPlay in other cars and never had this problem.
 

·
Registered
Joined
·
15 Posts
It's true that the smaller head unit on the Premium and Base packages are kind of slow. It's worth getting a Limited for the 8" headunit, which works much better.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #8
It's true that the smaller head unit on the Premium and Base packages are kind of slow. It's worth getting a Limited for the 8" headunit, which works much better.


Not worth it to me, I'd rather buy an aftermarket stereo. This should not be a "premium" feature.
 
1 - 10 of 10 Posts
Top